Solução pagseguro-sdk-ruby não funciona

Comunidade

Ask a Question
Back to All

Solução pagseguro-sdk-ruby não funciona

Boa Noite, tenho uma aplicação em Ruby on Rails (versão 6.1.4.6), e quero integrar o Pagseguro utilizando a gem pagseguro-oficial disponibilizado pelo Pagseguro; e seguindo a doc da gem pagseguro-oficial (https://github.com/pagseguro/pagseguro-sdk-ruby) ao incluir a gem "pagseguro-oficial", "~> 2.5.0" no Gemfile e executar bundle install, esta apresentando o seguinte erro "Bundler could not find compatible versions for gem "i18n":
In Gemfile:
i18n (~> 0.7, < 2)

rails (~> 6.1.4.6) was resolved to 6.1.4.6, which depends on
  activesupport (= 6.1.4.6) was resolved to 6.1.4.6, which depends on
    i18n (>= 1.6, < 2)

pagseguro-oficial (~> 2.5.0) was resolved to 2.5.0, which depends on
  i18n (~> 0.7)"; inclui a gem i18n no Gemfile, mas o erro continua; esta gem esta descontinuada ? ou como resolver o problema ?